Re: [PATCH v3 2/2] [Outreachy][Patch v1] t3404: employing test_line_count() to replace test
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Oct 7, 2024, 04:38 UTC
- Message-ID
- <CAPig+cR7w-ZgkN8qDe+_zy_WJi6puoLVk9Wk+9TRuzW_-dAA=A@mail.gmail.com>
- In-Reply-To
- <37b1411ee2c420f1a8578d27a2f7d54ccd3f329f.1728230769.git.gitgitgadget@gmail.com>
On Sun, Oct 6, 2024 at 12:06 PM Usman Akinyemi via GitGitGadget <gitgitgadget@gmail.com> wrote:
Show 11 quoted lines
> Refactor t3404 to replace instances of `test` with `test_line_count()` > for checking line counts. This improves readability and aligns with Git's > current test practices. > > Signed-off-by: Usman Akinyemi <usmanakinyemi202@gmail.com> > --- > diff --git a/t/t3404-rebase-interactive.sh b/t/t3404-rebase-interactive.sh > @@ -281,7 +281,8 @@ test_expect_success 'stop on conflicting pick' ' > - test 4 = $(grep -v "^#" < .git/rebase-merge/done | wc -l) && > + grep -v "^#" < .git/rebase-merge/done > actual && > + test_line_count = 4 actual &&
Thanks. Both patches in this series look fine.
Let's consider this a successfully-completed microproject.