Re: [PATCH v2 0/7] t5520: tests for --[no-]autostash option
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Apr 3, 2016, 20:17 UTC
- Message-ID
- <CAPig+cR3diDfn893-ExKNZps=C7Z=M7DFAy-zbJzH3wKCmxVeQ@mail.gmail.com>
- In-Reply-To
- <1459619912-5445-1-git-send-email-mehul.jain2029@gmail.com>
On Sat, Apr 2, 2016 at 1:58 PM, Mehul Jain <mehul.jain2029@gmail.com> wrote:
Show 19 quoted lines
> The following series is applicable on mj/pull-rebase-autostash. > > Changes made vs v1: > * [Patch v1 4/5] is broken into three patches to increase > readability of the patches. > > * [Patch 4/5] Factor out code in two functions > test_pull_autostash() and test_pull_autostash_fail() > instead of test_rebase_autostash() and > test_rebase_no_autostash(). This leads to further > simplification of code. > > Also removed two for-loops as they didn't provided > the simplicity intended for. > > For-loop was over-intended. Corrected it. > > * Commit message for patches 1/5, 2/5, 3/5 are improved > as suggested by Eric in the previous round.
Thanks, this version was a pleasant read, much simpler and easier to digest than the previous round[1]. With or without addressing the few minor nits in my review (none of which warrant a re-roll), this entire series is:
Reviewed-by: Eric Sunshine <sunshine@sunshineco.com>
Mehul, feel free to add my Reviewed-by: if you happen to re-roll (or Junio can add it if he wants when he picks up the series).
[1]: http://thread.gmane.org/gmane.comp.version-control.git/290134