Re: [PATCH v2 1/5] replay: remove dead code and rearrange
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 30, 2025, 23:37 UTC
- Message-ID
- <CAPc5daUsZkwC-H0Am3JHozE-V3x0vF_Yw7EjZxkVcvtmtWzkOg@mail.gmail.com>
- In-Reply-To
- <CABPp-BEJV1XG62_hn_OiZ9q9S3jsyTP0VdOEzS4pME2rrkKFrg@mail.gmail.com>
Show 10 quoted lines
> > -static void determine_replay_mode(struct repository *repo, > > ... > > +static void populate_for_onto_or_advance_mode(struct repository *repo, > > ... > Renaming makes sense, but the new name is quite the mouthful, and it > feels slightly odd because "onto" is both a command line flag and a > variable -- and the variable value is used regardless of which command > line flag is used. Since the variable is used either way, there's a > risk someone might be confused by this function name. Maybe just > setup_replay_mode() ? Or maybe others have other suggestions?
After reading the above, the name that came to my mind is (curiously) determine_replay_mode() ;-).
> Looks fine otherwise.
Thanks.