Re: [PATCH 03/13] odb: adjust naming to free object sources
Patrick Steinhardt <ps@pks.im> writes:
Show 10 quoted lines
> The functions `free_object_directory()` and `free_object_directories()`
> are responsible for freeing a single object source or all object sources
> connected to an object database, respectively. The associated structure
> has been renamed from `struct object_directory` to `struct odb_source`
> recently though, so the names are somewhat stale nowadays.
>
> Rename them to mention the new struct name instead. Furthermore, while
> at it, adapt them to our modern naming schema where we first have the
> subject followed by a verb.
>
Nit: Would be nice to mention that he renaming was done as part of
a1e2581a1e (object-store: rename `object_directory` to `odb_source`,
2025-07-01).
The patch looks straightforward :)
[snip]