From: Karthik Nayak Date: Thu, 30 Oct 2025 10:41:32 GMT Subject: Re: [PATCH 03/13] odb: adjust naming to free object sources Message-ID: In-Reply-To: <20251024-b4-pks-odb-loose-backend-v1-3-1a4202273c38@pks.im> Patrick Steinhardt writes: > The functions `free_object_directory()` and `free_object_directories()` > are responsible for freeing a single object source or all object sources > connected to an object database, respectively. The associated structure > has been renamed from `struct object_directory` to `struct odb_source` > recently though, so the names are somewhat stale nowadays. > > Rename them to mention the new struct name instead. Furthermore, while > at it, adapt them to our modern naming schema where we first have the > subject followed by a verb. > Nit: Would be nice to mention that he renaming was done as part of a1e2581a1e (object-store: rename `object_directory` to `odb_source`, 2025-07-01). The patch looks straightforward :) [snip]