Re: [PATCH 05/13] object-file: introduce `struct odb_loose_source`
- From
Karthik Nayak <karthik.188@gmail.com>
- Date
- Oct 30, 2025, 10:47 UTC
- Message-ID
- <CAOLa=ZQdit7N0aQWyqYHAoO6nuXaU3QqZbQmsbp52jW8C-zbzA@mail.gmail.com>
- In-Reply-To
- <20251024-b4-pks-odb-loose-backend-v1-5-1a4202273c38@pks.im>
Patrick Steinhardt <ps@pks.im> writes:
> Currently, all state that relates to loose objects is held directly by > the `struct odb_source`. Introduce a new `struct odb_loose_source` to > hold the state instead so that it is entirely self-contained. >
I wonder if the naming should instead be `struct obd_source_loose` that way other backends (if added) would be something like:
struct obd_source_loose
struct obd_source_postgres
struct obd_source_mongoThis is easier to read and also for autocompletion it leads nicely into the 'obd_source_...' namespace.
The patch looks good.
[snip]