git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v6 00/11] add options to for-each-ref

From
Karthik Nayak <karthik.188@gmail.com>
Date
Jun 25, 2015, 08:46 UTC
Message-ID
<CAOLa=ZRHoFgELMtxbZpfTvu5-S7nMTguiuOiMQDnoOs3tHXb8A@mail.gmail.com>

v5 of this patch series can be found here : http://article.gmane.org/gmane.comp.version-control.git/272590

This is a continuation of my GSoC project to unify git tag -l, git branch -l and for-each-ref. Continued from this patch series : http://thread.gmane.org/gmane.comp.version-control.git/271563

Changes in v5: 03/11: grammatical changes. 04/11: grammatical changes. 05/11: remove unnecessary if statement and remove caps used in commit message. 06/11: use xcalloc instead of using a commit_list as we know the size of the array. 07/11: s/<object>/[<object>]/ as the object is optional. 08/11: rename parse_opt_commit_object_name() to parse_opt_commits(). 09/11: make branch.c also to use the macros. 11/11: s/<object>/[<object>]/ as the object is optional.

Changes in v6: Renamed the test file from t6301 to t6302 to avoid conflicts.

Thanks to Matthieu, Christian, Junio and Eric for the input on the last iteration.

-- Regards, Karthik Nayak

Next: Karthik Nayak
Message 1 of 25 in “add options to for-each-ref”
  1. 00/11 add options to for-each-refKarthik Nayak, Jun 25, 2015
  2. 01/11 t6302: for-each-ref tests for ref-filter APIsKarthik Nayak, Jun 25, 2015
  3. 02/11 tag: libify parse_opt_points_at()Karthik Nayak, Jun 25, 2015
  4. 03/11 ref-filter: implement '--points-at' optionKarthik Nayak, Jun 25, 2015
  5. Junio C HamanoJun 29, 2015
  6. Karthik NayakJun 29, 2015
  7. 04/11 for-each-ref: add '--points-at' optionKarthik Nayak, Jun 25, 2015
  8. Junio C HamanoJun 29, 2015
  9. Karthik NayakJun 29, 2015
  10. Junio C HamanoJun 29, 2015
  11. Karthik NayakJun 29, 2015
  12. 05/11 ref-filter: add parse_opt_merge_filter()Karthik Nayak, Jun 25, 2015
  13. 06/11 ref-filter: implement '--merged' and '--no-merged' optionsKarthik Nayak, Jun 25, 2015
  14. Junio C HamanoJun 29, 2015
  15. Junio C HamanoJun 29, 2015
  16. Karthik NayakJun 30, 2015
  17. Junio C HamanoJun 30, 2015
  18. Karthik NayakJun 30, 2015
  19. 07/11 for-each-ref: add '--merged' and '--no-merged' optionsKarthik Nayak, Jun 25, 2015
  20. 08/11 parse-option: rename parse_opt_with_commit()Karthik Nayak, Jun 25, 2015
  21. 09/11 parse-options.h: add macros for '--contains' optionKarthik Nayak, Jun 25, 2015
  22. 10/11 ref-filter: implement '--contains' optionKarthik Nayak, Jun 25, 2015
  23. 11/11 for-each-ref: add '--contains' optionKarthik Nayak, Jun 25, 2015
  24. Junio C HamanoJun 29, 2015
  25. Karthik NayakJun 29, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.