git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] submodule: avoid sentence-lego in translated string

From
MÅMartin Ågren <martin.agren@gmail.com>
Date
Oct 9, 2017, 04:14 UTC
Message-ID
<CAN0heSqFSiev8BeZVu3KBA5vswsbQrrOH=tYYOSs_h_eq=8-3Q@mail.gmail.com>
In-Reply-To
<CAPc5daVk+sPLmw4G_AghOVFeO5myKTADQjKr823U3xaQZK+43g@mail.gmail.com>
On 9 October 2017 at 03:30, Junio C Hamano <gitster@pobox.com> wrote:
Show 28 quoted lines
> On Mon, Oct 9, 2017 at 9:51 AM, brian m. carlson
> <sandals@crustytoothpaste.net> wrote:
>> On Sun, Oct 08, 2017 at 10:32:35AM +0100, Philip Oakley wrote:
>>> From: "Martin Ågren" <martin.agren@gmail.com>
>>> > - die(_("submodule entry '%s' (%s) is a %s, not a commit"),
>>> > -     cb->path, oid_to_hex(oid), typename(type));
>>> > + die(_("submodule entry '%s' (%s) is not a commit"),
>>> > +     cb->path, oid_to_hex(oid));
>>> Bikeshed,
>>> maybe:
>>> "submodule entry '%s' (%s) is not a commit. It is a %s"
>>> This puts the two parts in separate sentences?
>>
>> Languages with multiple grammatical genders are going to have problems
>> with this.  In French, "a tree" is "un arbre" (masculine), but "a tag"
>> is "une étiquette" (feminine).  We don't currently have a Spanish
>> translation, but this would break there as well.
>>
>> Splitting the article out with the type name is still problematic for
>> languages where articles vary by case, like German, since the
>> translation might be reused in another place requiring a different case.
>
> While all of the above is correct, would we really need to subject typename()
> to translation? IOW, can't we just treat 'blob', 'tree', 'commit' and
> 'tag' as-is,
> as terms of art (i.e. with a specific or precise meaning within a
> given discipline
> or field and might have a different meaning in common usage)?

In another subthread, I sort of suggested "... is of type '%s', not 'commit'". So "commit" and "%s" would appear as the file-format-level terms that they are. I think it looks odd but I guess it might work in Swedish, FWIW.

In this particular case, we could have three specific messages plus one default message (which at the time shouldn't ever occur). Or we have one specific message for the "tag"-case, which seems to have been Stefan's original motivation, and a generic message for the other cases.

Previous: Junio C HamanoNext: Stefan Beller
Message 7 of 13 in “[L10N] Kickoff of translation for Git 2.15.0 round 1”
  1. Jiang XinOct 8, 2017
  2. submodule: avoid sentence-lego in translated stringMartin Ågren, Oct 8, 2017
  3. Philip OakleyOct 8, 2017
  4. Martin ÅgrenOct 8, 2017
  5. brian m. carlsonOct 9, 2017
  6. Junio C HamanoOct 9, 2017
  7. Martin ÅgrenOct 9, 2017
  8. Stefan BellerOct 9, 2017
  9. Jean-Noël AVILAOct 9, 2017
  10. Junio C HamanoOct 10, 2017
  11. Changwoo RyuOct 10, 2017
  12. Martin ÅgrenOct 10, 2017
  13. i18n: add a missing space in messageJean-Noel Avila, Oct 8, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.