Re: [PATCH] t6500: don't run detached auto gc at the end of the test script
- From
SZEDER Gábor <szeder.dev@gmail.com>
- Date
- Apr 10, 2017, 16:56 UTC
- Message-ID
- <CAM0VKjkdqjbkqOF6ucymtuBAAgBVJQ6SGe4Ep2gqVBtNp=s_CA@mail.gmail.com>
- In-Reply-To
- <20170410163557.gn3mlcalfhhncbtt@sigill.intra.peff.net>
On Mon, Apr 10, 2017 at 6:35 PM, Jeff King <peff@peff.net> wrote:
> On Mon, Apr 10, 2017 at 06:31:54PM +0200, SZEDER Gábor wrote:
Show 12 quoted lines
>> This means we can write this simply as: >> >> doesnt_matter=$(git gc --auto 9>&1) >> >> It's still hackery :) > > Heh. Yeah, I would call that _more_ hackery in that it's much more > clever. But it is shorter. :) > > I think as long as the trickery is documented that's OK (and calling it > doesnt_matter and explaining in the commit message is fine by me; > hopefully that name would induce somebody to look in the history).
For the sake of self documentation and potential future users, I will put it into a helper function like run_and_wait_for_detached_auto_gc() or something. Jury is still out on the proper function name (it would be a shame if the funcname were longer than the command ;), but time is up for today...