Re: [PATCH v3] gc: reject if another gc is running, unless --force is given
Show 15 quoted lines
>>> After reading what the whole function does, I think the purpose of
>>> this function is to take gc-lock (with optionally force). Perhaps a
>>> name along the lines of "lock_gc", "gc_lock", "lock_repo_for_gc",
>>> would be more appropriate.
>>
>> The whole point of this exercise is to _not_ lock up the repo during
>> gc,...
>
> I do not think it is a misnomer to call the entity that locks other
> instances of gc's "a lock on the repository for gc". Nothing in
> Duy's code suggests any other commands paying attention to this
> mechanism and stalling, and I think my comments were clear enough
> that I was not suggesting such a change.
>
> So I am not sure what you are complaining.
Not complaining; I wrote it down because of your "lock_repo_for_gc" suggestion.