Re: [PATCH] rebase -i: fix has_action
- From
Sverre Rabbelier <srabbelier@gmail.com>
- Date
- Aug 5, 2011, 12:36 UTC
- Message-ID
- <CAGdFq_j2wRw-gB109VypZkG1u=fm7yynkn2-Gu8AzNpVOrun8w@mail.gmail.com>
- In-Reply-To
- <7vliv93r9g.fsf@alter.siamese.dyndns.org>
Heya,
On Thu, Aug 4, 2011 at 21:34, Junio C Hamano <gitster@pobox.com> wrote:
> has_action () {
> test -s "$1"
> }> has_action () {
> sane_grep -v -e '^#' -e '^[ ]*$' "$1" >/dev/null
> }I think the former more correctly checks what the function name implies, is there any downside to that which makes you suggest this second approach?
-- Cheers, Sverre Rabbelier