From: Sverre Rabbelier Date: Fri, 05 Aug 2011 12:36:00 GMT Subject: Re: [PATCH] rebase -i: fix has_action Message-ID: In-Reply-To: <7vliv93r9g.fsf@alter.siamese.dyndns.org> Heya, On Thu, Aug 4, 2011 at 21:34, Junio C Hamano wrote: >        has_action () { >          test -s "$1" >        } >        has_action () { >          sane_grep -v -e '^#' -e '^[   ]*$' "$1" >/dev/null >        } I think the former more correctly checks what the function name implies, is there any downside to that which makes you suggest this second approach? -- Cheers, Sverre Rabbelier