git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/2] xdiff: implement empty line chunk heuristic

From
Stefan Beller <sbeller@google.com>
Date
May 2, 2016, 17:45 UTC
Message-ID
<CAGZ79kamc6keMC2foVieBjZctrHie+wizLzZC3YDS9uBGRCVzQ@mail.gmail.com>
In-Reply-To
<xmqqfuu0uzn7.fsf@gitster.mtv.corp.google.com>
On Mon, May 2, 2016 at 10:40 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 8 quoted lines
> "Keller, Jacob E" <jacob.e.keller@intel.com> writes:
>
>> True. I think the chances that it needs such a thing are quite minor,
>> and if an undocumented knob gets exposed it would have to become
>> documented and maintained, so I'd prefer to avoid it. Given that the
>> risk is pretty small I think that's ok.
>
> OK, then let's do only the "documentation" part.
The patch below looks good to me.

Thanks, Stefan

Show 53 quoted lines
>
> -- >8 --
> Subject: [PATCH] diff: undocument the compaction heuristic knobs for experimentation
>
> It seems that people around here are all happy with the updated
> heuristics used to decide where the hunks are separated.  Let's keep
> that as the default.  Even though we do not expect too much trouble
> from the difference between the old and the new algorithms, just in
> case let's leave the implementation of the knobs to turn it off for
> emergencies.  There is no longer need for documenting them, though.
>
> Signed-off-by: Junio C Hamano <gitster@pobox.com>
> ---
>  Documentation/diff-config.txt  | 5 -----
>  Documentation/diff-options.txt | 6 ------
>  2 files changed, 11 deletions(-)
>
> diff --git a/Documentation/diff-config.txt b/Documentation/diff-config.txt
> index 9bf3e92..6eaa452 100644
> --- a/Documentation/diff-config.txt
> +++ b/Documentation/diff-config.txt
> @@ -166,11 +166,6 @@ diff.tool::
>
>  include::mergetools-diff.txt[]
>
> -diff.compactionHeuristic::
> -       Set this option to enable an experimental heuristic that
> -       shifts the hunk boundary in an attempt to make the resulting
> -       patch easier to read.
> -
>  diff.algorithm::
>         Choose a diff algorithm.  The variants are as follows:
>  +
> diff --git a/Documentation/diff-options.txt b/Documentation/diff-options.txt
> index b513023..3ad6404 100644
> --- a/Documentation/diff-options.txt
> +++ b/Documentation/diff-options.txt
> @@ -63,12 +63,6 @@ ifndef::git-format-patch[]
>         Synonym for `-p --raw`.
>  endif::git-format-patch[]
>
> ---compaction-heuristic::
> ---no-compaction-heuristic::
> -       These are to help debugging and tuning an experimental
> -       heuristic that shifts the hunk boundary in an attempt to
> -       make the resulting patch easier to read.
> -
>  --minimal::
>         Spend extra time to make sure the smallest possible
>         diff is produced.
> --
> 2.8.2-458-gacc1066
>
Previous: Junio C HamanoNext: Jeff King
Message 16 of 19 in “[PATCHv5 0/2] xdiff: implement empty line chunk heuristic”
  1. Stefan BellerApr 19, 2016
  2. 1/2 xdiff: add recs_match helper functionStefan Beller, Apr 19, 2016
  3. 2/2 xdiff: implement empty line chunk heuristicStefan Beller, Apr 19, 2016
  4. Junio C HamanoApr 19, 2016
  5. Jeff KingApr 20, 2016
  6. Jeff KingApr 20, 2016
  7. Stefan BellerApr 20, 2016
  8. Junio C HamanoApr 29, 2016
  9. Jacob KellerApr 29, 2016
  10. Junio C HamanoApr 29, 2016
  11. Stefan BellerApr 29, 2016
  12. Keller, Jacob EApr 29, 2016
  13. Stefan BellerApr 29, 2016
  14. Keller, Jacob EApr 29, 2016
  15. Junio C HamanoMay 2, 2016
  16. Stefan BellerMay 2, 2016
  17. Jeff KingMay 2, 2016
  18. Jacob KellerMay 3, 2016
  19. Jeff KingApr 30, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.