Re: [PATCH 2/8] run-command: Call get_next_task with a clean child process.
- From
Stefan Beller <sbeller@google.com>
- Date
- Oct 21, 2015, 21:07 UTC
- Message-ID
- <CAGZ79kacfCG67yRLhM000wdxGxFCXXB840hiEd_vKRmOn7EzeQ@mail.gmail.com>
- In-Reply-To
- <xmqqh9lkufpt.fsf@gitster.mtv.corp.google.com>
On Wed, Oct 21, 2015 at 1:30 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 19 quoted lines
> Junio C Hamano <gitster@pobox.com> writes: > >> And of course we already have these array-clear calls in >> finish_command(). >> >> So I agree that deinit helper should exist, but >> >> * it should be file-scope static; >> >> * it should be called by finish_command(); and >> >> * if you are calling it from collect_finished(), then existing >> calls to array-clear should go. >> >> Other than that, this looks good. > > I'll queue this instead (the above squashed in and description > corrected). >
Thanks, Stefan