From: Stefan Beller Date: Wed, 21 Oct 2015 21:07:32 GMT Subject: Re: [PATCH 2/8] run-command: Call get_next_task with a clean child process. Message-ID: In-Reply-To: On Wed, Oct 21, 2015 at 1:30 PM, Junio C Hamano wrote: > Junio C Hamano writes: > >> And of course we already have these array-clear calls in >> finish_command(). >> >> So I agree that deinit helper should exist, but >> >> * it should be file-scope static; >> >> * it should be called by finish_command(); and >> >> * if you are calling it from collect_finished(), then existing >> calls to array-clear should go. >> >> Other than that, this looks good. > > I'll queue this instead (the above squashed in and description > corrected). > Thanks, Stefan