Re: [PATCH 2/8] refs.c: rename the transaction functions
- From
Stefan Beller <sbeller@google.com>
- Date
- Dec 11, 2014, 21:48 UTC
- Message-ID
- <CAGZ79kZVWzvneL=1_5Wp7ANw2A67pjZi08A6g5Y5YN670+RnXQ@mail.gmail.com>
- In-Reply-To
- <xmqqbnn9eudc.fsf@gitster.dls.corp.google.com>
On Thu, Dec 11, 2014 at 1:42 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 22 quoted lines
> Stefan Beller <sbeller@google.com> writes: > >> Rename the transaction functions. Remove the leading ref_ from the >> names and append _ref to the names for functions that create/delete/ >> update sha1 refs. >> >> The goal in the long term is to have different things running through >> the transaction api, such as the .git/config file. >> >> The dream is to... > > I was trying to polish somebody else's topic that does not have > anythning to do with refs/reflogs/transactions today, and had to > suffer from conflicts from the textual difference between > transaction_begin and ref_transaction_begin, which I feel is totally > unnecessary at this moment. > > I'd really prefer to see this done long after all the dust from > "ref" changes from various people have settled, especially given > that we are not doing anything for that "dream" right now. > > Thanks.
Good point. For the last days I was trying to write less invasive patches as I guessed this may become a problem.
Feel free to drop these patches, I'll resend them later if they still make sense.