Re: [PATCH 1/9] Add and use generic name->id mapping code for color slot parsing
- From
Stefan Beller <sbeller@google.com>
- Date
- May 10, 2018, 17:16 UTC
- Message-ID
- <CAGZ79kYnzQM-mcAm7Q3C=q+uhvt8MYvWrhkUrsyu1FbM2=1Z8g@mail.gmail.com>
- In-Reply-To
- <20180510141927.23590-2-pclouds@gmail.com>
On Thu, May 10, 2018 at 7:19 AM, Nguyễn Thái Ngọc Duy <pclouds@gmail.com> wrote:
> 7 files changed, 82 insertions(+), 112 deletions(-)
Nice!
>
> +static const char *color_branch_slots[] = {
> + [BRANCH_COLOR_RESET] = "reset",In 512f41cfac5 (clean.c: use designated initializer, 2017-07-14) we thought we'll do it once and see if anyone complains (and it shipped v2.15.0, 2017-10-29), and so far nobody complained half a year later. So designated initializers are all good now? Do we want to mention this decision in the commit message?
If so, the patch looks good! Thanks, Stefan