Re: [PATCH 1/9] Add and use generic name->id mapping code for color slot parsing
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- May 11, 2018, 07:22 UTC
- Message-ID
- <CACsJy8AYEbV6niTqaJ4XtVjHpXZ65-=9-vpGtxUHbuXVmc8paw@mail.gmail.com>
- In-Reply-To
- <CAGZ79kYnzQM-mcAm7Q3C=q+uhvt8MYvWrhkUrsyu1FbM2=1Z8g@mail.gmail.com>
On Thu, May 10, 2018 at 7:16 PM, Stefan Beller <sbeller@google.com> wrote:
Show 16 quoted lines
> On Thu, May 10, 2018 at 7:19 AM, Nguyễn Thái Ngọc Duy <pclouds@gmail.com> wrote:
>
>> 7 files changed, 82 insertions(+), 112 deletions(-)
>
> Nice!
>
>
>>
>> +static const char *color_branch_slots[] = {
>> + [BRANCH_COLOR_RESET] = "reset",
>
> In 512f41cfac5 (clean.c: use designated initializer, 2017-07-14)
> we thought we'll do it once and see if anyone complains
> (and it shipped v2.15.0, 2017-10-29), and so far
> nobody complained half a year later. So designated initializers
> are all good now?I don't know :) but it's worth pushing. I don't think this series would land on the next release, which gives people a couple more months to complain about C99. It does save me time and if it causes problem, removing designated initializers is trivial
Show 5 quoted lines
> Do we want to mention this decision in the commit message? > > If so, the patch looks good! > Thanks, > Stefan
-- Duy