Re: [PATCH 2/8] evolve: Implement oid_array_contains_nondestructive
- From
Stefan Beller <sbeller@google.com>
- Date
- Jan 22, 2019, 19:51 UTC
- Message-ID
- <CAGZ79kYiE+VhQw4GMs_VM6kK5yXAQ8An0o4fCVSZ3gr2+rHwiA@mail.gmail.com>
- In-Reply-To
- <20190121223216.66659-2-sxenos@google.com>
On Mon, Jan 21, 2019 at 2:32 PM <sxenos@google.com> wrote:
>
> evolve: Implement oid_array_contains_nondestructive
I'd think I would word this
sha1-array: implement oid_array_contains_nondestructive
as for this patch it is not relevant what we we'll be using it for later, but rather that it touches the oidset class?
Show 9 quoted lines
> From: Stefan Xenos <sxenos@gmail.com> > > Implement a "contains_nondestructive" function for oid_array that won't > sort the array if it is unsorted. This can be used to test containment in > the rare situations where the array order matters. > > The function has intentionally been given a name that is more cumbersome > than the "lookup" function, which is what most callers will will want > in most situations.
What about naming it oid_array_linear_lookup instead? That would still have the common "lookup" in the name and the "linear" should be enough to scare away the casual user. The non-destructive sounds scary.
Missing sign off