Re: [PATCH 2/8] evolve: Implement oid_array_contains_nondestructive
- From
- Stefan Xenos <sxenos@google.com>
- Date
- Jan 27, 2019, 19:08 UTC
- Message-ID
- <CAPL8Ziuce2D4iLzkAguzjVvLq8iZXxE_UwxtU7TVKB0D7bG-dA@mail.gmail.com>
- In-Reply-To
- <CAGZ79kYiE+VhQw4GMs_VM6kK5yXAQ8An0o4fCVSZ3gr2+rHwiA@mail.gmail.com>
On Tue, Jan 22, 2019 at 11:51 AM Stefan Beller <sbeller@google.com> wrote:
Show 9 quoted lines
> > On Mon, Jan 21, 2019 at 2:32 PM <sxenos@google.com> wrote: > > > > > evolve: Implement oid_array_contains_nondestructive > > I'd think I would word this > > sha1-array: implement oid_array_contains_nondestructive
Good point. Done.
Show 17 quoted lines
> as for this patch it is not relevant what we we'll be using it for > later, but rather that it touches the oidset class? > > > From: Stefan Xenos <sxenos@gmail.com> > > > > Implement a "contains_nondestructive" function for oid_array that won't > > sort the array if it is unsorted. This can be used to test containment in > > the rare situations where the array order matters. > > > > The function has intentionally been given a name that is more cumbersome > > than the "lookup" function, which is what most callers will will want > > in most situations. > > What about naming it oid_array_linear_lookup instead? > That would still have the common "lookup" in the name and > the "linear" should be enough to scare away the casual > user. The non-destructive sounds scary.
It probably shouldn't contain the word "lookup" since the lookup method returns an index and this new method returns true/false. I changed it to oid_array_readonly_contains.
> Missing sign off
Thanks!