From: Stefan Beller Date: Tue, 22 Jan 2019 19:51:16 GMT Subject: Re: [PATCH 2/8] evolve: Implement oid_array_contains_nondestructive Message-ID: In-Reply-To: <20190121223216.66659-2-sxenos@google.com> On Mon, Jan 21, 2019 at 2:32 PM wrote: > > evolve: Implement oid_array_contains_nondestructive I'd think I would word this sha1-array: implement oid_array_contains_nondestructive as for this patch it is not relevant what we we'll be using it for later, but rather that it touches the oidset class? > From: Stefan Xenos > > Implement a "contains_nondestructive" function for oid_array that won't > sort the array if it is unsorted. This can be used to test containment in > the rare situations where the array order matters. > > The function has intentionally been given a name that is more cumbersome > than the "lookup" function, which is what most callers will will want > in most situations. What about naming it oid_array_linear_lookup instead? That would still have the common "lookup" in the name and the "linear" should be enough to scare away the casual user. The non-destructive sounds scary. Missing sign off