Re: [RFC PATCH 01/10] pack: move pack name-related functions
- From
Stefan Beller <sbeller@google.com>
- Date
- Aug 8, 2017, 20:36 UTC
- Message-ID
- <CAGZ79kYQP74fTu1hFDLyKhS-2NTbUhtirWTxRMNavgO09SenYg@mail.gmail.com>
- In-Reply-To
- <368a1095557aa5f68cebd4d4e08628351c03b843.1502220307.git.jonathantanmy@google.com>
On Tue, Aug 8, 2017 at 12:32 PM, Jonathan Tan <jonathantanmy@google.com> wrote:
Show 7 quoted lines
> Currently, sha1_file.c and cache.h contain many functions, both related > to and unrelated to packfiles. This makes both files very large and > causes an unclear separation of concerns. > > Create a new file, pack.c, to hold all packfile-related functions > currently in sha1_file.c, and designate pack.h to hold these > packfile-related functions.
There are also packed refs, so one could (like I did) think that pack.c is for generic packing of things, maybe packfile.c would be more clear?