Re: [RFC PATCH 01/10] pack: move pack name-related functions
- From
- Jonathan Tan <jonathantanmy@google.com>
- Date
- Aug 8, 2017, 20:50 UTC
- Message-ID
- <20170808135001.48f2440e@twelve2.svl.corp.google.com>
- In-Reply-To
- <CAGZ79kYQP74fTu1hFDLyKhS-2NTbUhtirWTxRMNavgO09SenYg@mail.gmail.com>
On Tue, 8 Aug 2017 13:36:24 -0700 Stefan Beller <sbeller@google.com> wrote:
Show 12 quoted lines
> On Tue, Aug 8, 2017 at 12:32 PM, Jonathan Tan <jonathantanmy@google.com> wrote: > > Currently, sha1_file.c and cache.h contain many functions, both related > > to and unrelated to packfiles. This makes both files very large and > > causes an unclear separation of concerns. > > > > Create a new file, pack.c, to hold all packfile-related functions > > currently in sha1_file.c, and designate pack.h to hold these > > packfile-related functions. > > There are also packed refs, so one could (like I did) think that > pack.c is for generic packing of things, maybe packfile.c > would be more clear?
Good point. I'll use packfile.c and packfile.h in the next version.