git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 11/30] directory rename detection: testcases exploring possibly suboptimal merges

From
Stefan Beller <sbeller@google.com>
Date
Nov 14, 2017, 20:33 UTC
Message-ID
<CAGZ79kYCDBFwMhW4Qgwhomiv4kKRWS53cjMLuRG1NxrzULYwgg@mail.gmail.com>
In-Reply-To
<20171110190550.27059-12-newren@gmail.com>
On Fri, Nov 10, 2017 at 11:05 AM, Elijah Newren <newren@gmail.com> wrote:
Show 37 quoted lines
> Signed-off-by: Elijah Newren <newren@gmail.com>
> ---
>  t/t6043-merge-rename-directories.sh | 371 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 371 insertions(+)
>
> diff --git a/t/t6043-merge-rename-directories.sh b/t/t6043-merge-rename-directories.sh
> index 115d0d2622..bdfd943c88 100755
> --- a/t/t6043-merge-rename-directories.sh
> +++ b/t/t6043-merge-rename-directories.sh
> @@ -1683,4 +1683,375 @@ test_expect_failure '7e-check: transitive rename in rename/delete AND dirs in th
>         test $(git hash-object y/d~C^0) = $(git rev-parse A:x/d)
>  '
>
> +
> +###########################################################################
> +# SECTION 8: Suboptimal merges
> +#
> +# As alluded to in the last section, the ruleset we have built up for
> +# detecting directory renames unfortunately has some special cases where it
> +# results in slightly suboptimal or non-intuitive behavior.  This section
> +# explores these cases.
> +#
> +# To be fair, we already had non-intuitive or suboptimal behavior for most
> +# of these cases in git before introducing implicit directory rename
> +# detection, but it'd be nice if there was a modified ruleset out there
> +# that handled these cases a bit better.
> +###########################################################################
> +
> +# Testcase 8a, Dual-directory rename, one into the others' way
> +#   Commit A. x/{a,b},   y/{c,d}
> +#   Commit B. x/{a,b,e}, y/{c,d,f}
> +#   Commit C. y/{a,b},   z/{c,d}
> +#
> +# Possible Resolutions:
> +#   Previous git: y/{a,b,f},   z/{c,d},   x/e
> +#   Expected:     y/{a,b,e,f}, z/{c,d}
> +#   Preferred:    y/{a,b,e},   z/{c,d,f}

it might be tricky in the future to know what "previous git" is; "Previous git" means without directory renames enabled;

"expected" means we expect the algorithm presented in this series to produce this output, preferred is what we actually expect.

Show 5 quoted lines
> +#
> +# Note: Both x and y got renamed and it'd be nice to detect both, and we do
> +# better with directory rename detection than git did previously, but the
> +# simple rule from section 5 prevents me from handling this as optimally as
> +# we potentially could.
which were:
   If a subset of to-be-renamed files have a file or directory in the way,
   "turn off" the directory rename for those specific sub-paths, falling
   back to old handling.  But, sadly, see testcases 8a and 8b.

The tricky part is y in this example as x,y "swapped" its content in C, and moved 'old y content' to the new z/.

Makes sense, but I agree it might be painful to debug such a case from a users point of view.

Show 10 quoted lines
> +
> +# Testcase 8b, Dual-directory rename, one into the others' way, with conflicting filenames
> +#   Commit A. x/{a_1,b_1},     y/{a_2,b_2}
> +#   Commit B. x/{a_1,b_1,e_1}, y/{a_2,b_2,e_2}
> +#   Commit C. y/{a_1,b_1},     z/{a_2,b_2}
> +#
> +# Possible Resolutions:
> +#   Previous git: y/{a_1,b_1,e_2}, z/{a_2,b_2}, x/e_1
> +#   Scary:        y/{a_1,b_1},     z/{a_2,b_2}, CONFLICT(add/add, e_1 vs. e_2)
> +#   Preferred:    y/{a_1,b_1,e_1}, z/{a_2,b_2,e_2}

It may be common to have sub directories with the same path having different blobs, e.g. when having say multiple hardware configurations in different sub directories configured. Then renaming becomes a pain when they overlap.

> +# Note: Very similar to 8a, except instead of 'e' and 'f' in directories x and
> +# y, both are named 'e'.  Without directory rename detection, neither file
> +# moves directories.  Implment directory rename detection suboptimally, and
Implement
Show 7 quoted lines
> +# you get an add/add conflict, but both files were added in commit B, so this
> +# is an add/add conflict where one side of history added both files --
> +# something we can't represent in the index.  Obviously, we'd prefer the last
> +# resolution, but our previous rules are too coarse to allow it.  Using both
> +# the rules from section 4 and section 5 save us from the Scary resolution,
> +# making us fall back to pre-directory-rename-detection behavior for both
> +# e_1 and e_2.
ok, so add "Expected" as well? (repeating "Previous git", or so?)
Show 11 quoted lines
> +
> +# Testcase 8c, rename+modify/delete
> +#   (Related to testcases 5b and 8d)
> +#   Commit A: z/{b,c,d}
> +#   Commit B: y/{b,c}
> +#   Commit C: z/{b,c,d_modified,e}
> +#   Expected: y/{b,c,e}, CONFLICT(rename+modify/delete: x/d -> y/d or deleted)
> +#
> +#   Note: This testcase doesn't present any concerns for me...until you
> +#         compare it with testcases 5b and 8d.  See notes in 8d for more
> +#         details.
Makes sense.
> +# Testcase 8d, rename/delete...or not?
> +#   (Related to testcase 5b; these may appear slightly inconsistent to users;
> +#    Also related to testcases 7d and 7e)
> +#   Commit A: z/{b,c,d}
> +#   Commit B: y/{b,c}
> +#   Commit C: z/{b,c,d,e}
> +#   Expected: y/{b,c,e}
Why this?
* d is deleted in B and not found in the result
* the rename detection also worked well in z->y  for adding e
I do not see the confusion, yet.
Show 18 quoted lines
> +#   Note: It would also be somewhat reasonable to resolve this as
> +#             y/{b,c,e}, CONFLICT(rename/delete: x/d -> y/d or deleted)
> +#   The logic being that the only difference between this testcase and 8c
> +#   is that there is no modification to d.  That suggests that instead of a
> +#   rename/modify vs. delete conflict, we should just have a rename/delete
> +#   conflict, otherwise we are being inconsistent.
> +#
> +#   However...as far as consistency goes, we didn't report a conflict for
> +#   path d_1 in testcase 5b due to a different file being in the way.  So,
> +#   we seem to be forced to have cases where users can change things
> +#   slightly and get what they may perceive as inconsistent results.  It
> +#   would be nice to avoid that, but I'm not sure I see how.
> +#
> +#   In this case, I'm leaning towards: commit B was the one that deleted z/d
> +#   and it did the rename of z to y, so the two "conflicts" (rename vs.
> +#   delete) are both coming from commit B, which is non-sensical.  Conflicts
> +#   during merging are supposed to be about opposite sides doing things
> +#   differently.
  "Sensical has not yet become an "official" word in the English language, which
  would be why you can't use it. Nonsense is a word, therefore nonsensical can
  used to describe something of nonsense. However, sense has different meanings
  and doesn't have an adjective for something of sense"

from https://english.stackexchange.com/questions/38582/antonym-of-nonsensical I don't mind it, the spell checker just made me go on a detour. Maybe illogical?

Show 22 quoted lines
> +# Testcase 8e, Both sides rename, one side adds to original directory
> +#   Commit A: z/{b,c}
> +#   Commit B: y/{b,c}
> +#   Commit C: w/{b,c}, z/d
> +#
> +# Possible Resolutions:
> +#   Previous git: z/d, CONFLICT(z/b -> y/b vs. w/b), CONFLICT(z/c -> y/c vs. w/c)
> +#   Expected:     y/d, CONFLICT(z/b -> y/b vs. w/b), CONFLICT(z/c -> y/c vs. w/c)
> +#   Preferred:    ??
> +#
> +# Notes: In commit B, directory z got renamed to y.  In commit C, directory z
> +#        did NOT get renamed; the directory is still present; instead it is
> +#        considered to have just renamed a subset of paths in directory z
> +#        elsewhere.  Therefore, the directory rename done in commit B to z/
> +#        applies to z/d and maps it to y/d.
> +#
> +#        It's possible that users would get confused about this, but what
> +#        should we do instead?   Silently leaving at z/d seems just as bad or
> +#        maybe even worse.  Perhaps we could print a big warning about z/d
> +#        and how we're moving to y/d in this case, but when I started thinking
> +#        abouty the ramifications of doing that, I didn't know how to rule out
> +#        that opening other weird edge and corner cases so I just punted.
s/about/abouty
It sort of makes sense from a users POV.
Previous: Elijah NewrenNext: Elijah Newren
Message 12 of 81 in “Add directory rename detection to git”
  1. 00/30 Add directory rename detection to gitElijah Newren, Nov 10, 2017
  2. 01/30 Tighten and correct a few testcases for merging and cherry-pickingElijah Newren, Nov 10, 2017
  3. Stefan BellerNov 13, 2017
  4. 24/30 merge-recursive: Add computation of collisions due to dir rename & mergingElijah Newren, Nov 10, 2017
  5. René ScharfeJun 10, 2018
  6. René ScharfeJun 10, 2018
  7. Jeff KingJun 10, 2018
  8. Elijah NewrenJun 11, 2018
  9. Junio C HamanoJun 14, 2018
  10. 23/30 merge-recursive: Add a new hashmap for storing file collisionsElijah Newren, Nov 10, 2017
  11. 11/30 directory rename detection: testcases exploring possibly suboptimal mergesElijah Newren, Nov 10, 2017
  12. Stefan BellerNov 14, 2017
  13. Elijah NewrenNov 14, 2017
  14. 16/30 merge-recursive: Introduce new functions to handle rename logicElijah Newren, Nov 10, 2017
  15. Junio C HamanoNov 14, 2017
  16. Junio C HamanoNov 14, 2017
  17. Elijah NewrenNov 14, 2017
  18. 09/30 directory rename detection: testcases checking which side did the renameElijah Newren, Nov 10, 2017
  19. Stefan BellerNov 14, 2017
  20. Elijah NewrenNov 14, 2017
  21. 06/30 directory rename detection: testcases to avoid taking detection too farElijah Newren, Nov 10, 2017
  22. Stefan BellerNov 13, 2017
  23. Elijah NewrenNov 14, 2017
  24. 08/30 directory rename detection: files/directories in the way of some renamesElijah Newren, Nov 10, 2017
  25. Stefan BellerNov 14, 2017
  26. Elijah NewrenNov 14, 2017
  27. 05/30 directory rename detection: directory splitting testcasesElijah Newren, Nov 10, 2017
  28. Stefan BellerNov 13, 2017
  29. 07/30 directory rename detection: partially renamed directory testcase/discussionElijah Newren, Nov 10, 2017
  30. Stefan BellerNov 14, 2017
  31. 26/30 merge-recursive: When comparing files, don't include treesElijah Newren, Nov 10, 2017
  32. 29/30 merge-recursive: Fix overwriting dirty files involved in renamesElijah Newren, Nov 10, 2017
  33. 12/30 directory rename detection: miscellaneous testcases to complete coverageElijah Newren, Nov 10, 2017
  34. Stefan BellerNov 15, 2017
  35. Elijah NewrenNov 16, 2017
  36. 10/30 directory rename detection: more involved edge/corner testcasesElijah Newren, Nov 10, 2017
  37. Stefan BellerNov 14, 2017
  38. Elijah NewrenNov 14, 2017
  39. Stefan BellerNov 14, 2017
  40. 14/30 directory rename detection: tests for handling overwriting dirty filesElijah Newren, Nov 10, 2017
  41. 15/30 merge-recursive: Move the get_renames() functionElijah Newren, Nov 10, 2017
  42. Junio C HamanoNov 14, 2017
  43. Elijah NewrenNov 14, 2017
  44. Junio C HamanoNov 15, 2017
  45. 22/30 merge-recursive: Check for directory level conflictsElijah Newren, Nov 10, 2017
  46. 19/30 merge-recursive: Split out code for determining diff_filepairsElijah Newren, Nov 10, 2017
  47. Junio C HamanoNov 14, 2017
  48. 13/30 directory rename detection: tests for handling overwriting untracked filesElijah Newren, Nov 10, 2017
  49. 27/30 merge-recursive: Apply necessary modifications for directory renamesElijah Newren, Nov 10, 2017
  50. Stefan BellerNov 15, 2017
  51. Elijah NewrenNov 16, 2017
  52. 18/30 merge-recursive: Make !o->detect_rename codepath more obviousElijah Newren, Nov 10, 2017
  53. 17/30 merge-recursive: Fix leaks of allocated renames and diff_filepairsElijah Newren, Nov 10, 2017
  54. Junio C HamanoNov 14, 2017
  55. 28/30 merge-recursive: Avoid clobbering untracked files with directory renamesElijah Newren, Nov 10, 2017
  56. 30/30 merge-recursive: Fix remaining directory rename + dirty overwrite casesElijah Newren, Nov 10, 2017
  57. 21/30 merge-recursive: Add get_directory_renames()Elijah Newren, Nov 10, 2017
  58. Junio C HamanoNov 14, 2017
  59. Elijah NewrenNov 14, 2017
  60. 25/30 merge-recursive: Check for file level conflicts then get new nameElijah Newren, Nov 10, 2017
  61. 20/30 merge-recursive: Add a new hashmap for storing directory renamesElijah Newren, Nov 10, 2017
  62. 02/30 merge-recursive: Fix logic ordering issueElijah Newren, Nov 10, 2017
  63. Stefan BellerNov 13, 2017
  64. Elijah NewrenNov 13, 2017
  65. Stefan BellerNov 13, 2017
  66. Elijah NewrenNov 13, 2017
  67. Stefan BellerNov 13, 2017
  68. 04/30 directory rename detection: basic testcasesElijah Newren, Nov 10, 2017
  69. Stefan BellerNov 13, 2017
  70. Elijah NewrenNov 14, 2017
  71. Stefan BellerNov 14, 2017
  72. Elijah NewrenNov 14, 2017
  73. Junio C HamanoNov 14, 2017
  74. 03/30 merge-recursive: Add explanation for src_entry and dst_entryElijah Newren, Nov 10, 2017
  75. Stefan BellerNov 13, 2017
  76. Elijah NewrenNov 13, 2017
  77. Stefan BellerNov 13, 2017
  78. Junio C HamanoNov 14, 2017
  79. Philip OakleyNov 10, 2017
  80. Elijah NewrenNov 10, 2017
  81. Philip OakleyNov 13, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.