Re: [PATCH v15 01/27] bisect--helper: use OPT_CMDMODE instead of OPT_BOOL
- From
Pranit Bauva <pranit.bauva@gmail.com>
- Date
- Oct 14, 2016, 15:12 UTC
- Message-ID
- <CAFZEwPOjK25m84BgTF7AL72DL_K1dHf7OrYoX=_vky9r3GayNw@mail.gmail.com>
- In-Reply-To
- <01020157c38b19e0-81123fa5-5d9d-4f64-8f1b-ff336e83ebe4-000000@eu-west-1.amazonses.com>
Hey everyone,
It took me some time to get to the next version as I was a bit preoccupied with my assignments and exams. The diff between the v14[1] and v15[2] can be found here[3] because gmail web client will wrap the lines. Thanks Junio for the reviews in v14. I have tried to solves every issue raised in the previous round.
The major changes in this series are:
* Use the char * instead of struct strbuf in struct bisect_terms.
* Use goto mechanism for error handling.
* Use get_sha1_committish() instead of just get_oid() because there
is also ^{commit} at the end of the call from shell.
* Use skip_prefix() where ever required.
* Use return error() instead of die() where ever possible.
* Restructure a part in bisect_start() to make it more readable.
* Change the comments in bisect.c to use return instead of exit
because the code does it.
* Introduce a test to check for cleanups in after bad merge base to
make the patch 15/28 more understood.
* Also keeping comments in bisect.c to show at which places there
would be cleanups and where not.
* Restructure bisect_replay() and get_next_word().[1]: http://public-inbox.org/git/01020156b73fe5b4-5dc768ab-b73b-4a21-ab92-018e2a7aa6f7-000000@eu-west-1.amazonses.com/T/#m7c26060fcf95abbd19f93742d7317eef87b915a1 [2]: http://public-inbox.org/git/01020157c38b19e0-81123fa5-5d9d-4f64-8f1b-ff336e83ebe4-000000@eu-west-1.amazonses.com/T/#u [3]: http://paste.ubuntu.com/23323581/
Regards, Pranit Bauva