Re: [PATCH v2 2/5] test-ref-store: tweaks to for-each-reflog-ent format
- From
Han-Wen Nienhuys <hanwen@google.com>
- Date
- Sep 7, 2021, 13:33 UTC
- Message-ID
- <CAFQ2z_Oen0Q5hfpbZdzWgJ8D=EetBNGx7sQ3ZxnJSXC-tSKGYw@mail.gmail.com>
- In-Reply-To
- <878s09nxh1.fsf@evledraar.gmail.com>
On Tue, Sep 7, 2021 at 12:35 AM Ævar Arnfjörð Bjarmason <avarab@gmail.com> wrote:
Show 11 quoted lines
> > - printf("%s %s %s %"PRItime" %d %s\n",
> > - oid_to_hex(old_oid), oid_to_hex(new_oid),
> > - committer, timestamp, tz, msg);
> > + printf("%s %s %s %" PRItime " %+05d\t%s\n", oid_to_hex(old_oid),
> > + oid_to_hex(new_oid), committer, timestamp, tz, msg);
>
> Nit: Would be a more readable diff if this wasn't a
> line-wrap-while-at-it change in addition to changing the format string.
>
> I.e. the last 4x parameters aren't changed, so leaving them on their own
> line & just changing the string & the two oid_to_hex()...This is clang-format's output, and the new code takes up less lines vertically.
If you think this is really, really important, I can change it, but I think it's a better use of everyone's time to leave mechanical tasks (like formatting) to the machines.
-- Han-Wen Nienhuys - Google Munich I work 80%. Don't expect answers from me on Fridays. -- Google Germany GmbH, Erika-Mann-Strasse 33, 80636 Munich Registergericht und -nummer: Hamburg, HRB 86891 Sitz der Gesellschaft: Hamburg Geschäftsführer: Paul Manicle, Halimah DeLaine Prado