Re: [PATCH v2 2/5] test-ref-store: tweaks to for-each-reflog-ent format
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Sep 6, 2021, 22:34 UTC
- Message-ID
- <878s09nxh1.fsf@evledraar.gmail.com>
- In-Reply-To
- <11b296a55e9e450575c64ade1a2cb93a1886b9da.1630947142.git.gitgitgadget@gmail.com>
On Mon, Sep 06 2021, Han-Wen Nienhuys via GitGitGadget wrote:
Show 24 quoted lines
> From: Han-Wen Nienhuys <hanwen@google.com>
>
> Follow the reflog format more closely, so it can be used for comparing
> reflogs in tests without using inspecting files under .git/logs/
>
> Signed-off-by: Han-Wen Nienhuys <hanwen@google.com>
> ---
> t/helper/test-ref-store.c | 5 ++---
> t/t1405-main-ref-store.sh | 1 +
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/t/helper/test-ref-store.c b/t/helper/test-ref-store.c
> index b314b81a45b..0fcad9b3812 100644
> --- a/t/helper/test-ref-store.c
> +++ b/t/helper/test-ref-store.c
> @@ -151,9 +151,8 @@ static int each_reflog(struct object_id *old_oid, struct object_id *new_oid,
> const char *committer, timestamp_t timestamp,
> int tz, const char *msg, void *cb_data)
> {
> - printf("%s %s %s %"PRItime" %d %s\n",
> - oid_to_hex(old_oid), oid_to_hex(new_oid),
> - committer, timestamp, tz, msg);
> + printf("%s %s %s %" PRItime " %+05d\t%s\n", oid_to_hex(old_oid),
> + oid_to_hex(new_oid), committer, timestamp, tz, msg);Nit: Would be a more readable diff if this wasn't a line-wrap-while-at-it change in addition to changing the format string.
I.e. the last 4x parameters aren't changed, so leaving them on their own line & just changing the string & the two oid_to_hex()...