Re: [PATCH 3/3] strbuf.[ch]: make strbuf_fread() take hint, not size
- From
Han-Wen Nienhuys <hanwen@google.com>
- Date
- Jul 7, 2021, 11:47 UTC
- Message-ID
- <CAFQ2z_MWMokX8hXdOJfiL9Yn=F-QUWe5VHXFEF5DoSBBJu=dmw@mail.gmail.com>
- In-Reply-To
- <patch-3.3-46c65a7ae12-20210707T103712Z-avarab@gmail.com>
On Wed, Jul 7, 2021 at 12:39 PM Ævar Arnfjörð Bjarmason <avarab@gmail.com> wrote:
> > Change the strbuf_fread() function to take a "size_t hint" instead of > a "size_t size", for consistency with e.g. strbuf_read(). We can then
Making strbuf_fread and strbuf_read consistent is weird because they do different things. strbuf_read reads from fd until it's exhausted, while strbuf_fread reads up to the size specified. So the argument isn't really a hint.
shouldn't you rename it to strbuf_fread_once, analogous to strbuf_read_once ?
bonus points for making the argument ordering consistent between strbuf_fread and strbuf_read
-- Han-Wen Nienhuys - Google Munich I work 80%. Don't expect answers from me on Fridays. -- Google Germany GmbH, Erika-Mann-Strasse 33, 80636 Munich Registergericht und -nummer: Hamburg, HRB 86891 Sitz der Gesellschaft: Hamburg Geschäftsführer: Paul Manicle, Halimah DeLaine Prado