Re: [PATCH v2] Handle atexit list internaly fo unthreaded builds
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Oct 13, 2014, 00:56 UTC
- Message-ID
- <CACsJy8CbhS=dv3fHvyTv0b-jazh3XS+nswmz_0AsLeHqko794g@mail.gmail.com>
- In-Reply-To
- <1413104974-3861-1-git-send-email-etienne.buira@gmail.com>
On Sun, Oct 12, 2014 at 4:09 PM, Etienne Buira <etienne.buira@gmail.com> wrote:
> Replace atexit()s calls with cmd_atexit that is atexit() on threaded > builds, but handles the callbacks list internally for unthreaded builds.
Maybe hide this in git-compat-util.h and "#define atexit(x) cmd_atexit(x)"? cmd_ is usually for commands' "main" functions. Maybe rename it to git_atexit().
-- Duy