Re: [PATCH v2] Handle atexit list internaly for unthreaded builds
On Mon, Oct 13, 2014 at 2:56 AM, Duy Nguyen <pclouds@gmail.com> wrote:
Show 6 quoted lines
> On Sun, Oct 12, 2014 at 4:09 PM, Etienne Buira <etienne.buira@gmail.com> wrote:
> > Replace atexit()s calls with cmd_atexit that is atexit() on threaded
> > builds, but handles the callbacks list internally for unthreaded builds.
>
> Maybe hide this in git-compat-util.h and "#define atexit(x)
> cmd_atexit(x)"?
> cmd_ is usually for commands' "main" functions. Maybe
> rename it to git_atexit().
Indeed, renamed. Thank you.