From: Duy Nguyen Date: Mon, 13 Oct 2014 00:56:05 GMT Subject: Re: [PATCH v2] Handle atexit list internaly fo unthreaded builds Message-ID: In-Reply-To: <1413104974-3861-1-git-send-email-etienne.buira@gmail.com> On Sun, Oct 12, 2014 at 4:09 PM, Etienne Buira wrote: > Replace atexit()s calls with cmd_atexit that is atexit() on threaded > builds, but handles the callbacks list internally for unthreaded builds. Maybe hide this in git-compat-util.h and "#define atexit(x) cmd_atexit(x)"? cmd_ is usually for commands' "main" functions. Maybe rename it to git_atexit(). -- Duy