Re: [PATCH 1/5] read-cache: add watchman 'WAMA' extension
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Nov 3, 2015, 19:17 UTC
- Message-ID
- <CACsJy8Bb0BVsCdgDQe9JWPUOR9Hw+963Zph3HMZA6Zmzr2THMA@mail.gmail.com>
- In-Reply-To
- <1446501799.4131.24.camel@twopensource.com>
On Mon, Nov 2, 2015 at 11:03 PM, David Turner <dturner@twopensource.com> wrote:
Show 6 quoted lines
> On Sun, 2015-11-01 at 14:55 +0100, Nguyễn Thái Ngọc Duy wrote: >> >>+#define CE_NO_WATCH (0x0001) > > This name seems very confusing to me. CE_NO_WATCHMAN_STAT? > CE_UNKNOWN_TO_WATCHMAN?
Files that are known updated. Maybe CE_WATCHMAN_DIRTY?
Show 11 quoted lines
> (one reason it may seem more confusing to me than to others is that
> Twitter's code has a concept of files that we don't watch at all e.g.
> Intellij's .idea dir).
>
>> @@ -322,6 +325,7 @@ struct index_state {
>> struct untracked_cache *untracked;
>> void *mmap;
>> size_t mmap_size;
>> + char *last_update;
>
> Might be worth a comment explaining what this is.It's the clock value from watchman when we query file status. Will make a note. Or maybe I should just rename it to watchman_clock.
-- Duy