Re: [PATCH 1/5] read-cache: add watchman 'WAMA' extension
- From
David Turner <dturner@twopensource.com>
- Date
- Nov 2, 2015, 22:03 UTC
- Message-ID
- <1446501799.4131.24.camel@twopensource.com>
- In-Reply-To
- <1446386146-10438-2-git-send-email-pclouds@gmail.com>
On Sun, 2015-11-01 at 14:55 +0100, Nguyễn Thái Ngọc Duy wrote:
> >+#define CE_NO_WATCH (0x0001)
This name seems very confusing to me. CE_NO_WATCHMAN_STAT? CE_UNKNOWN_TO_WATCHMAN?
(one reason it may seem more confusing to me than to others is that Twitter's code has a concept of files that we don't watch at all e.g. Intellij's .idea dir).
Show 5 quoted lines
> @@ -322,6 +325,7 @@ struct index_state {
> struct untracked_cache *untracked;
> void *mmap;
> size_t mmap_size;
> + char *last_update;Might be worth a comment explaining what this is.