Re: [PATCH 1/2] Documentation: replace sha1 by SHA-1
- From
Felipe Contreras <felipe.contreras@gmail.com>
- Date
- Apr 25, 2009, 10:47 UTC
- Message-ID
- <94a0d4530904250347s55a66f47gbaaf5ea42d0c4eac@mail.gmail.com>
- In-Reply-To
- <7vzle5ad8n.fsf@gitster.siamese.dyndns.org>
On Sat, Apr 25, 2009 at 1:38 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 23 quoted lines
> Jeff King <peff@peff.net> writes: > >> On Fri, Apr 24, 2009 at 04:49:34PM +0200, Michael J Gruber wrote: >> >>> --- a/Documentation/git-cat-file.txt >>> +++ b/Documentation/git-cat-file.txt >>> @@ -76,7 +76,7 @@ If '--batch' is specified, output of the following form is printed for each >>> object specified on stdin: >>> >>> ------------ >>> -<sha1> SP <type> SP <size> LF >>> +<SHA-1> SP <type> SP <size> LF >>> <contents> LF >>> ------------ >> >> Maybe it is just me, but I find the original for this one easier to >> read. Perhaps because <sha1> is really a variable name here (but for a >> human reader to interpret instead of a compiler), so I find the >> punctuation and capitalization distracting. >> >> I wonder if all <sha1> should simply be left as-is. > > Or spell them using their official terminology "object name".
Why is the "official" terminology "object name", wouldn't "id" work better?
SHA-1 is simply one hash function, what git has been referring to "sha1" is actually the SHA-1 digest. This digest has been used as a checksum (or hash sum) but also as a unique identifier, therefore "id" would work just fine.
-- Felipe Contreras