Re: A suggestion: more readable human commands
- From
Andreas Schwab <schwab@linux-m68k.org>
- Date
- Jun 15, 2021, 11:55 UTC
- Message-ID
- <87o8c7wdes.fsf@igel.home>
- In-Reply-To
- <fa2e886dd03a26c945d9deffe6f96d48@abelardolg.com>
On Jun 15 2021, it-developer@abelardolg.com wrote:
Show 7 quoted lines
> To merge a single file from one branch to another: > > git checkout <branch_name> <path_to_file> --patch > > would be like more readable human like this: > > git merge <path_file> to <dst_branch>
This is ambigous if a branch or tag named <path_file> or to exists, and the usual disambiguation using -- will not work.
Andreas.
-- Andreas Schwab, schwab@linux-m68k.org GPG Key fingerprint = 7578 EB47 D4E5 4D69 2510 2552 DF73 E780 A9DA AEC1 "And now for something completely different."