Re: [PATCH 6/8] CodingGuidelines: call the conditional statement "if ()", not "if()"
- From
David Kastrup <dak@gnu.org>
- Date
- May 1, 2014, 18:36 UTC
- Message-ID
- <87d2fxz6py.fsf@fencepost.gnu.org>
- In-Reply-To
- <xmqqfvktcqsx.fsf@gitster.dls.corp.google.com>
Junio C Hamano <gitster@pobox.com> writes:
Show 12 quoted lines
> David Kastrup <dak@gnu.org> writes: > >>> - - We try to avoid assignments inside if(). >>> + - We try to avoid assignments inside "if ()" condition. >> >> That's not grammatical. > > OK, > > ... inside the condition part of an "if ()" statement. > > then?
... in the condition of an "if" statement
is what I would write. "if ()" statement is mixing name and shorthand for the statement.
-- David Kastrup