Re: [PATCH 1/3] Rename patch_update_file function to patch_update_pathspec
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Nov 25, 2007, 18:11 UTC
- Message-ID
- <7vzlx2mc02.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <1195996542-86074-2-git-send-email-win@wincent.com>
Wincent Colaiuta <win@wincent.com> writes:
> The patch_update_file function really works on pathspecs, not files, so > rename it to reflect its actual purpose.
I do not think this is a correct change. patch_update_file() should work on files not pathspecs.
A list of exact pathnames are valid pathspecs, and because the matching function takes exact match first, if you feed a command (e.g. diff-files) paths expanded from the pathspec given by the user, you should be able to get desired results, no?
patch_update_cmd() grabs list of modified _files_, not pathspecs. Then the user chooses the ones to select hunks from via list_and_choose(), and you may want to pretend that everything was chosen if you are operating with pathspec and with --patch option. Iterating over them is iterating over files, not pathspecs, at that point.
Have you tried the one that is in 'next'? I think it does the right thing except "the bogus pathspec validation at the beginning" part as far as the pathspec handling is concerned.
I sent out two fixes on top of the series.