Re: [PATCH] http.c: fix parsing of http.sslCertPasswordProtected variable
Mark Lodato <lodatom@gmail.com> writes:
Show 11 quoted lines
> On Fri, Jul 12, 2013 at 3:52 PM, Junio C Hamano <gitster@pobox.com> wrote:
>>
>> Jonathan Nieder <jrnieder@gmail.com> writes:
>>
>> > FWIW the GIT_SSL_CERT_PASSWORD_PROTECTED envvar has a similar "can
>> > only enable" behavior, but since it's documented, that's not as big
>> > of a problem. Do you remember why it was written that way?
>>
>> Not me ;-).
>
> Because that's how GIT_NO_VERIFY, GIT_CURL_FTP_NO_EPSV, and
s/GIT_NO_VERIFY/GIT_SSL_NO_VERIFY/, I think.
> GIT_CURL_VERBOSE (and perhaps others) work. That said, I agree that
> parsing the variable's value as a boolean would make much more sense.
> Perhaps this is how all of those variables should work?
I think you are probably right.