From: Junio C Hamano Date: Mon, 15 Jul 2013 04:13:09 GMT Subject: Re: [PATCH] http.c: fix parsing of http.sslCertPasswordProtected variable Message-ID: <7vzjtoea0a.fsf@alter.siamese.dyndns.org> In-Reply-To: Mark Lodato writes: > On Fri, Jul 12, 2013 at 3:52 PM, Junio C Hamano wrote: >> >> Jonathan Nieder writes: >> >> > FWIW the GIT_SSL_CERT_PASSWORD_PROTECTED envvar has a similar "can >> > only enable" behavior, but since it's documented, that's not as big >> > of a problem. Do you remember why it was written that way? >> >> Not me ;-). > > Because that's how GIT_NO_VERIFY, GIT_CURL_FTP_NO_EPSV, and s/GIT_NO_VERIFY/GIT_SSL_NO_VERIFY/, I think. > GIT_CURL_VERBOSE (and perhaps others) work. That said, I agree that > parsing the variable's value as a boolean would make much more sense. > Perhaps this is how all of those variables should work? I think you are probably right.