Re: [PATCH 1/2] git-submodule: replace duplicated code with a module_list function
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 22, 2008, 22:53 UTC
- Message-ID
- <7vpro064qz.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <edc9ece47ca86c3c3e4265e7f4222c8ea6917461.1219390139.git.davvid@gmail.com>
David Aguilar <davvid@gmail.com> writes:
Show 22 quoted lines
> @@ -54,6 +54,15 @@ resolve_relative_url ()
> }
>
> #
> +# Get submodule info for registered submodules
> +# $@ = path to limit submodule list
> +#
> +module_list()
> +{
> + git ls-files --stage -- "$@" | grep '^160000 '
> +}
> +
> +#
> # Map submodule path to submodule name
> #
> # $1 = path
> @@ -206,7 +215,7 @@ cmd_add()
> #
> cmd_foreach()
> {
> - git ls-files --stage | grep '^160000 ' |
> + module_list |Thanks.
I think the original "foreach" implementation does not pay attention to "$@" not by design but by mistake, and we should pass "$@" here as well.
Other than that I do not see anything obviously wrong with the patch.
Mark?