Re: [PATCH 1/2] git-submodule: replace duplicated code with a module_list function
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 23, 2008, 00:08 UTC
- Message-ID
- <7v8wuo619x.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <48AF533E.9020102@gmail.com>
Mark Levedahl <mlevedahl@gmail.com> writes:
Show 9 quoted lines
> Actually, this was by design, not mistake, though we did not discuss > this at all. I'm not sure what the semantics would / should be: first > of all, some part of "$@" is the command to be executed in each > submodule, and as written "$@" in its entirety is what is used. Also, > as written and documented, foreach operates in each checked out > submodule, not a subset. I guess the basic questions are: > a) What specific option or options to git ls-files makes sense here? > b) How do we distinguish the ls-files options from the command to be > executed?
Ah, I was blind. For (a) I do not see any need for "option" but pathspecs; and (b) I agree is a real problem. We of course could do something like:
$ git submodule foreach -c 'your command here' your pathspec here