From: Junio C Hamano Date: Fri, 22 Aug 2008 22:53:40 GMT Subject: Re: [PATCH 1/2] git-submodule: replace duplicated code with a module_list function Message-ID: <7vpro064qz.fsf@gitster.siamese.dyndns.org> In-Reply-To: David Aguilar writes: > @@ -54,6 +54,15 @@ resolve_relative_url () > } > > # > +# Get submodule info for registered submodules > +# $@ = path to limit submodule list > +# > +module_list() > +{ > + git ls-files --stage -- "$@" | grep '^160000 ' > +} > + > +# > # Map submodule path to submodule name > # > # $1 = path > @@ -206,7 +215,7 @@ cmd_add() > # > cmd_foreach() > { > - git ls-files --stage | grep '^160000 ' | > + module_list | Thanks. I think the original "foreach" implementation does not pay attention to "$@" not by design but by mistake, and we should pass "$@" here as well. Other than that I do not see anything obviously wrong with the patch. Mark?