Show 23 quoted lines
> Junio C Hamano <gitster@pobox.com> writes:
>
>> Jeff King <peff@peff.net> writes:
>>
>>> On Sat, Apr 07, 2012 at 09:49:47AM +0200, Michael Haggerty wrote:
>>> ...
>>>> If "push.default" is not set, then have it default to "beginner" mode.
>>>
>>> I would be fine with that (I've suggested it elsewhere in the thread,
>>> though I think I stole the idea originally from you. Speaking of going
>>> in circles. :) ).
>>
>> This makes the first priority for 1.7.10 cycle to come up with a solid
>> implementation of the "beginner" mode, I guess.
>
> I guess so. I found the idea relevant the first time it came in the
> discussion, and I'm starting to get really convinced that this is the
> way to go. And if we're wrong, it will be much easier to migrate to
> either "current" or "upstream" later.
>
> No time to code this right now, but I may come up with a patch in a few
> days. Any idea on the real name? I'd call it "safeUpstream" or
> "safeCurrent", but that's probably by lack of a better name.