Re: [PATCH 2/3] Make has_commit non-static
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 26, 2009, 20:06 UTC
- Message-ID
- <7v63k16dd0.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <alpine.DEB.1.00.0901261637300.25749@intel-tinevez-2-302>
Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
Show 12 quoted lines
> On Mon, 26 Jan 2009, Jake Goulding wrote: > >> Moving has_commit from branch to a common location in preparation for >> using it in tag. Renaming it to commit_has_any_in_commit_list to be more >> unique. > > I feel like bike-shedding for a change, and I'd also like to prove that > not all Germans like long names: > > is_ancestor_of_any() > > Hmm?
Is it ancestor or descendant? The latter makes the name longer, though ;-)