git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/3] Make has_commit non-static

From
Jake Goulding <goulding@vivisimo.com>
Date
Jan 26, 2009, 19:20 UTC
Message-ID
<497E0CFE.4080702@vivisimo.com>
In-Reply-To
<alpine.DEB.1.00.0901261637300.25749@intel-tinevez-2-302>
Johannes Schindelin wrote:
Show 14 quoted lines
> Hi,
> 
> On Mon, 26 Jan 2009, Jake Goulding wrote:
> 
>> Moving has_commit from branch to a common location in preparation for 
>> using it in tag. Renaming it to commit_has_any_in_commit_list to be more 
>> unique.
> 
> I feel like bike-shedding for a change, and I'd also like to prove that 
> not all Germans like long names:
> 
> 	is_ancestor_of_any()
> 
> Hmm?
I assume that this means that the rest of the code/logic is fine? :-D

I'll change this (I don't have any attachment to one name or the other), then it should be good to go!

-Jake
Previous: Johannes SchindelinNext: Junio C Hamano
Message 5 of 9 in “Make opt_parse_with_commit non-static”
  1. 1/3 Make opt_parse_with_commit non-staticJake Goulding, Jan 26, 2009
  2. 2/3 Make has_commit non-staticJake Goulding, Jan 26, 2009
  3. 3/3 Add --contains flag to git tagJake Goulding, Jan 26, 2009
  4. Johannes SchindelinJan 26, 2009
  5. Jake GouldingJan 26, 2009
  6. Junio C HamanoJan 26, 2009
  7. Johannes SchindelinJan 26, 2009
  8. Junio C HamanoJan 28, 2009
  9. Jake GouldingFeb 3, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.