Re: [PATCH 34/48] merge-recursive: Consolidate process_entry() and process_df_entry()
Elijah Newren <newren@gmail.com> writes:
Show 13 quoted lines
> The whole point of adding process_df_entry() was to ensure that files of
> D/F conflicts were processed after paths under the corresponding
> directory. However, given that the entries are in sorted order, all we
> need to do is iterate through them in reverse order to achieve the same
> effect. That lets us remove some duplicated code, and lets us keep
> track of one less thing as we read the code ("do we need to make sure
> this is processed before process_df_entry() or do we need to defer it
> until then?").
>
> Signed-off-by: Elijah Newren <newren@gmail.com>
> ---
> merge-recursive.c | 194 ++++++++++++++++------------------------------------
> 1 files changed, 60 insertions(+), 134 deletions(-)