From: Junio C Hamano Date: Thu, 21 Jul 2011 18:43:20 GMT Subject: Re: [PATCH 34/48] merge-recursive: Consolidate process_entry() and process_df_entry() Message-ID: <7v39hz325z.fsf@alter.siamese.dyndns.org> In-Reply-To: <1307518278-23814-35-git-send-email-newren@gmail.com> Elijah Newren writes: > The whole point of adding process_df_entry() was to ensure that files of > D/F conflicts were processed after paths under the corresponding > directory. However, given that the entries are in sorted order, all we > need to do is iterate through them in reverse order to achieve the same > effect. That lets us remove some duplicated code, and lets us keep > track of one less thing as we read the code ("do we need to make sure > this is processed before process_df_entry() or do we need to defer it > until then?"). > > Signed-off-by: Elijah Newren > --- > merge-recursive.c | 194 ++++++++++++++++------------------------------------ > 1 files changed, 60 insertions(+), 134 deletions(-) ;-).