Re: [PATCH v9 07/11] sequencer.c: remove duplicate code
- From
- Phillip Wood <phillip.wood123@gmail.com>
- Date
- Mar 26, 2019, 10:44 UTC
- Message-ID
- <69e3e5b7-58ec-4507-bc5c-c162393368c4@gmail.com>
- In-Reply-To
- <492ba73797ac66cc48da2b44cdae2152b41aa481.1553150827.git.liu.denton@gmail.com>
On 21/03/2019 06:53, Denton Liu wrote:
Show 14 quoted lines
> Since we implemented get_cleanup_mode, we had some duplicate code in > git_sequencer_config which essentially performed the same operations. > Refactor git_sequencer_config to take advantage of the logic already in > get_cleanup_mode. > > Note that we had to introduce a separate argument to get_cleanup_mode > indicating whether to die or not on an invalid value. This is because if > we are parsing a config, we do not want to die but instead, we only want > to warn the user, whereas if we are parsing a command-line option, we > would like to actually die. > > Finally, this is almost a no-op refactor but not quite. Previously, in > the case that an invalid value is presented, default_msg_cleanup would > not be set.
Looking more closely at the code that's not correct, we set a default value before in sequencer_init_config() which unfortunately means my previous concerns about needing different values for rebase were not correct.
> We change the behaviour so that default_msg_cleanup will now > take on the value as if "default" were provided as the cleanup_arg.
That is not the default value we want, if the user provides an invalid value in the config we're better off using --verbatim which is what the current code does.
While looking at all this I noticed that in run_git_commit() we set up the cleanup option for to use with
if ((flags & CLEANUP_MSG))
argv_array_push(&cmd.args, "--cleanup=strip");
if ((flags & EDIT_MSG))
argv_array_push(&cmd.args, "-e");
else if (!(flags & CLEANUP_MSG) &&
!opts->signoff && !opts->record_origin &&
git_config_get_value("commit.cleanup", &value))
argv_array_push(&cmd.args, "--cleanup=verbatim");So we use --strip when editing (we always set CLEANUP_MSG when EDIT_MSG is set) otherwise if opts->signoff or opts->record_origin is set we use commit's default cleanup which is --whitespace as we're not editing unless the user has set something else. In all other cases we use --verbatim unless the user has something set in their config.
With your changes we need to change git_config_get_value("commit.cleanup", &value) to something that checks to see if --cleanup was given on the command line as well. I think the best way is to add an opts->explict_cleanup flag which will also help with a bug I introduced when I wrote try_to_commit().
In try_to_commit() we do
cleanup = (flags & CLEANUP_MSG) ? COMMIT_MSG_CLEANUP_ALL : opts->default_msg_cleanup;
Which does not special case the opts->signoff or opts->record_origin cases (opts->default_msg_cleanup will be --verbatim unless the user has set something else) I'm planning to send in a patch for that soonish, it will involve adding opts->explicit_cleanup which will interact badly with this series as it is, I'll try and do some fixups to address that.
I have a general question about this series. If I run 'merge --cleanup=scissors' or 'cherry-pick --cleanup=scissors' and there are conflicts what happens when if I run 'commit --no-edit' to commit the conflict resolution - does it know which cleanup mode to use?
Best Wishes
Phillip
Show 84 quoted lines
> Also, we lowercase some user-facing strings.
>
> Helped-by: Phillip Wood <phillip.wood@dunelm.org.uk>
> Signed-off-by: Denton Liu <liu.denton@gmail.com>
> ---
> builtin/commit.c | 2 +-
> sequencer.c | 22 ++++++++--------------
> sequencer.h | 2 +-
> 3 files changed, 10 insertions(+), 16 deletions(-)
>
> diff --git a/builtin/commit.c b/builtin/commit.c
> index 8277da8474..ba1e6027ba 100644
> --- a/builtin/commit.c
> +++ b/builtin/commit.c
> @@ -1172,7 +1172,7 @@ static int parse_and_validate_options(int argc, const char *argv[],
> die(_("Only one of --include/--only/--all/--interactive/--patch can be used."));
> if (argc == 0 && (also || (only && !amend && !allow_empty)))
> die(_("No paths with --include/--only does not make sense."));
> - cleanup_mode = get_cleanup_mode(cleanup_arg, use_editor);
> + cleanup_mode = get_cleanup_mode(cleanup_arg, use_editor, 1);
>
> handle_untracked_files_arg(s);
>
> diff --git a/sequencer.c b/sequencer.c
> index 224c823b43..2cbfb848dd 100644
> --- a/sequencer.c
> +++ b/sequencer.c
> @@ -172,17 +172,7 @@ static int git_sequencer_config(const char *k, const char *v, void *cb)
> if (status)
> return status;
>
> - if (!strcmp(s, "verbatim"))
> - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_NONE;
> - else if (!strcmp(s, "whitespace"))
> - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_SPACE;
> - else if (!strcmp(s, "strip"))
> - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_ALL;
> - else if (!strcmp(s, "scissors"))
> - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_SPACE;
> - else
> - warning(_("invalid commit message cleanup mode '%s'"),
> - s);
> + opts->default_msg_cleanup = get_cleanup_mode(s, 0, 0);
>
> free((char *)s);
> return status;
> @@ -512,7 +502,7 @@ static int fast_forward_to(struct repository *r,
> }
>
> enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg,
> - int use_editor)
> + int use_editor, int die_on_error)
> {
> if (!cleanup_arg || !strcmp(cleanup_arg, "default"))
> return use_editor ? COMMIT_MSG_CLEANUP_ALL :
> @@ -526,8 +516,12 @@ enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg,
> else if (!strcmp(cleanup_arg, "scissors"))
> return use_editor ? COMMIT_MSG_CLEANUP_SCISSORS :
> COMMIT_MSG_CLEANUP_SPACE;
> - else
> - die(_("Invalid cleanup mode %s"), cleanup_arg);
> + else if (!die_on_error) {
> + warning(_("invalid cleanup mode %s, falling back to default"), cleanup_arg);
> + return use_editor ? COMMIT_MSG_CLEANUP_ALL :
> + COMMIT_MSG_CLEANUP_SPACE;
> + } else
> + die(_("invalid cleanup mode %s"), cleanup_arg);
> }
>
> void append_conflicts_hint(struct index_state *istate,
> diff --git a/sequencer.h b/sequencer.h
> index eb9bd97ef3..e7908f558e 100644
> --- a/sequencer.h
> +++ b/sequencer.h
> @@ -117,7 +117,7 @@ void append_signoff(struct strbuf *msgbuf, size_t ignore_footer, unsigned flag);
>
> void append_conflicts_hint(struct index_state *istate, struct strbuf *msgbuf);
> enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg,
> - int use_editor);
> + int use_editor, int die_on_error);
>
> void cleanup_message(struct strbuf *msgbuf,
> enum commit_msg_cleanup_mode cleanup_mode, int verbose);
>