Re: [PATCH 4/3] sha1_name: use bsearch_pack() in unique_in_pack()
On 3/24/2018 12:41 PM, René Scharfe wrote:
Show 9 quoted lines
> Replace the custom binary search in unique_in_pack() with a call to
> bsearch_pack(). This reduces code duplication and makes use of the
> fan-out table of packs.
>
> Signed-off-by: Rene Scharfe <l.s.r@web.de>
> ---
> This is basically the same replacement as done by patch 3. Speed is
> less of a concern here -- at least I don't know a commonly used
> command that needs to resolve lots of short hashes.
Thanks, René! Good teamwork on this patch series.
Reviewed-by: Derrick Stolee <dstolee@microsoft.com>