From: Derrick Stolee Date: Sun, 25 Mar 2018 18:21:00 GMT Subject: Re: [PATCH 4/3] sha1_name: use bsearch_pack() in unique_in_pack() Message-ID: <63f7e580-add1-2e5c-8720-c7982d993e00@gmail.com> In-Reply-To: <71b5cef0-abad-001f-6a23-3f2d874b9709@web.de> On 3/24/2018 12:41 PM, René Scharfe wrote: > Replace the custom binary search in unique_in_pack() with a call to > bsearch_pack(). This reduces code duplication and makes use of the > fan-out table of packs. > > Signed-off-by: Rene Scharfe > --- > This is basically the same replacement as done by patch 3. Speed is > less of a concern here -- at least I don't know a commonly used > command that needs to resolve lots of short hashes. Thanks, René! Good teamwork on this patch series. Reviewed-by: Derrick Stolee